Why I cannot use PostgreSQL PL/PGSQL Debugger?

Apply OS: Windows, Mac, Linux

Apply Navicat Product: Navicat for PostgreSQL, Navicat Premium

Apply Navicat Version No.: Version 11.2 or above

 

PL/PGSQL Debugger is supported for PostgreSQL 8.3 or above. The language of the function must be "plpgsql" and you need to install the pldbgapi extension in your database before using the PL/PGSQL Debugger.

 

PostgreSQL 8.3 to 9.0

You can follow the steps in PostgreSQL Installation Notes (the pl/pgsql Debugger section) which is available in your PostgreSQL server installation folder (e.g. C:\Program Files\PostgreSQL\8.3\doc\installation-notes.html).

Or, you can refer to this link - https://www.postgresql.org/message-id/attachment/2940//rtmp/installation-notes.html

 

PostgreSQL 9.1 or above

If you are using Navicat Windows or Linux version, you can simply right-click anywhere on the function object list in Navicat and choose Install pldbgapi Extension.

If you are using Navicat Mac version, you can follow the steps in PostgreSQL Installation Notes (the pl/pgsql Debugger section) which is available in your PostgreSQL server installation folder. (e.g. C:\Program Files\PostgreSQL\9.3\doc\installation-notes.html)

Have more questions? Submit Ticket.
Have more questions? Submit a request

0 Comments

Article is closed for comments.