Apply OS: Windows, Mac, Linux

Apply Navicat Product: All

Apply Navicat Version No.: All


To export table with binary data to a SQL file, you may use the Data Transfer function.

 

Version 11.2 or below:

  1. Select Tools > Data Transfer.
  2. In the General tab, select the source connection, database and table, and choose Transfer to file / File.
  3. Choose a location for the file.
  4. In the Advanced tab, check Use hexadecimal format for BLOB.
  5. Click Start.

 

Version 12 or above:

  1. Select Tools > Data Transfer.
  2. In the General tab, select the source connection and database, and choose File.
  3. Choose a location for the file.
  4. In the Options tab, check Use hexadecimal format for BLOB.
  5. Click Next and select the table.
  6. Click Start.

 

Have more questions?
Submit Ticket