Apply OS: Windows, Mac, Linux

Apply Navicat Product: All

Apply Navicat Version No.: Version 9.x or above

 

Windows

  1. In Navicat, choose File > Export Connections. The exported file (.ncx) contains all your connection settings.
  2. Backup the exported file (.ncx).
  3. Uninstall Navicat from the existing computer.**
  4. Re-install Navicat in the new computer.
  5. Open Navicat and choose File > Import Connections in the new computer.

** If you are using version 11 or above, please deactivate the registration key before uninstall Navicat.

When a new connection being established, Navicat will create a subfolder (with name in line with respective database) under the Settings Save Path/Settings Location. All backup (.psc, .psb), reports (.rtm), queries (.sql), import/export profile etc are stored within this subfolder. To look for the path, right-click the connection and choose Connection Properties/Edit Connection > Advanced > Settings Save Path/Settings Location.

In addition, all the saved profiles (e.g batch job profile) are stored in Profiles Save Path/Profiles Location. To look for the path, select Tools > Options, under Miscellaneous/File Locations.

 

Mac

  1. In Navicat, control-click anywhere in the Connection pane and choose Export Connections. The exported file (.ncx) contains all your connection settings (without passwords).
  2. Backup the exported file (.ncx).
  3. Uninstall Navicat from the existing computer.**
  4. Re-install Navicat in the new computer.
  5. Control-click anywhere in the Connection pane and choose Import Connections in the new computer.

** If you are using version 11 or above, please deactivate the registration key before uninstall Navicat.

When a new connection being established, Navicat will create a subfolder (with name in line with respective database) under the Settings Save Path/Settings Location. All backup (.pmb), queries (.sql) etc are stored within this subfolder. To look for the path, control-click the connection and choose Connection Properties/Edit Connection > Advanced > Settings Save Path/Settings Location.

 

Linux

  1. In Navicat, choose File > Export Connections. The exported file (.ncx) contains all your connection settings.
  2. Backup the exported file (.ncx).
  3. Uninstall Navicat from the existing computer.**
  4. Re-install Navicat in the new computer.
  5. Open Navicat and choose File > Import Connections in the new computer.

** If you are using version 11 or above, please deactivate the registration key before uninstall Navicat.

When a new connection being established, Navicat will create a subfolder (with name in line with respective database) under the Settings Save Path/Settings Location. All backup (.psc, .psb), queries (.sql), import/export profile etc are stored within this subfolder. To look for the path, right-click the connection and choose Connection Properties/Edit Connection > Advanced > Settings Save Path/Settings Location.

In addition, all the saved profiles (e.g batch job profile) are stored in Profiles Save Path/Profiles Location. To look for the path, select Tools > Options, under Miscellaneous/File Locations.

 

Have more questions?
Submit Ticket